Тема: Apache + ASP.NET
Показать сообщение отдельно

Старый 23.05.2011, 06:58   #5
Пользователь
 
Аватар для google
 
google вне форума
Регистрация: 15.01.2009
Адрес: Облако Цианида
Сообщений: 275
Отправить сообщение для google с помощью ICQ
По умолчанию

хы, и правда, обработчик не прописан был для *.aspx

Прописал, но теперь сообщает 404


немного напортачил в конфиге апача... ща перекину mono на другой порт и порпобую

пьянствовал пьянствовал, но так и доперло в чем проблема

Это раз:
cat /etc/apache2/sites-enabled/000-default:
<VirtualHost *:80>
ServerAdmin webmaster@localhost

DocumentRoot /var/www
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

Alias /doc/ "/usr/share/doc/"
<Directory "/usr/share/doc/">
Options Indexes MultiViews FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
Allow from 127.0.0.0/255.0.0.0 ::1/128
</Directory>

</VirtualHost>

<VirtualHost *:85>

DocumentRoot /var/www/asp

ErrorLog /var/www/asp/error_log
CustomLog /var/www/asp/access_log combined

MonoServerPath default /usr/bin/mod-mono-server2
AddMonoApplications default "nethome:/:/var/www/asp"

<Directory /var/www/asp/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all
DirectoryIndex index.aspx index.html Default.aspx default.aspx
AddHandler mono .aspx .ascx .asax .ashx .config .cs .asmx .axd
</Directory>

</VirtualHost>



Это два
cat /etc/apache2/ports.conf:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

NameVirtualHost *:85
Listen 85

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>


переназначил Mono на 85 порт и все работает вроде
__________________
Книга для тех, кто хочет научиться думать
username: В этом вашем интернете хрен поймешь, кто прикалывается, а кто реально дебил.

Последний раз редактировалось google; 23.05.2011 в 10:57..
  Ответить с цитированием